Lessonly Down
Incident Report for Lessonly
Resolved
Lessonly is up and running. Thank you all for your patience!
Posted Mar 01, 2023 - 21:08 EST
Investigating
Lessonly is currently not operating. Our team is actively investigating the issue.
Posted Mar 01, 2023 - 17:47 EST
This incident affected: Lessonly Web.