Hippo Videos Currently Cannot Be Viewed
Incident Report for Lessonly
Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 10:28 EDT
Investigating
Hippo videos cannot be viewed once uploaded. We are working with our partner to investigate and fix the issue.
Posted Jul 22, 2022 - 09:38 EDT
This incident affected: Video.